Gamme TI-82


Poster un nouveau sujet Poster une réponse
Traduire un algorithme algobox en tibasic ti 82
Auteur Message
JKNOEL
Invité
Posté le : Dim 29 Jan 2017, 14:44   Citer 

Bonjour, j'ai un algorithme algobox que je dois "traduire" en ti basic pour ma ti 82 pouvez vous m'aider?

L'algorithme :
VARIABLES
I EST_DU_TYPE NOMBRE
A EST_DU_TYPE NOMBRE
X EST_DU_TYPE NOMBRE
y EST_DU_TYPE NOMBRE
B EST_DU_TYPE NOMBRE
M EST_DU_TYPE NOMBRE
DEBUT_ALGORITHME
B PREND_LA_VALEUR 0
M PREND_LA_VALEUR 0
POUR X ALLANT_DE 1 A 1000
DEBUT_POUR
y PREND_LA_VALEUR 0
POUR I ALLANT_DE 1 A 3
DEBUT_POUR
A PREND_LA_VALEUR ALGOBOX_ALEA_ENT(1,6)
y PREND_LA_VALEUR y+A
FIN_POUR
SI (y==9) ALORS
DEBUT_SI
B PREND_LA_VALEUR B+1
FIN_SI
SI (y==10) ALORS
DEBUT_SI
M PREND_LA_VALEUR M+1
FIN_SI
FIN_POUR
AFFICHER "Le nombre 9 est apparu "
AFFICHER B
AFFICHER* " fois"
AFFICHER "Le nombre 10 est apparu "
AFFICHER M
AFFICHER* " fois"
FIN_ALGORITHME

  Haut de page Bas de page 
 
m@thieu41



Autorisation : Membre
Nb de messages : 855
Inscrit le : Mer 18 Juil 2012, 18:44
Posté le : Lun 30 Jan 2017, 20:45   Citer 

Bonjour,
Nous ne sommes pas des robots, nous ne sommes pas là pour faire les DM des autres.
Montre nous ce que tu as essayé de faire, on t'expliquera ce qu'il faut changer et pourquoi, au moins tu auras appris quelque chose.

----------------------
Pour vous aidez dans vos débuts (et même ensuite ^^) :
*Tuto Algo->Ti Basic (par Linkakro) : Traduisez vos algo (de type algobox) en prgm pour votre TI!
*Catalogue des emplacements et traductions (anglais/français) des fonctions sur la TI.
*Faites vos propres programmes de maths (par ash)

Et au fait: la politesse n'a jamais tué personne winkle.gif
 Adresse email Haut de page Bas de page 
 
Poster un nouveau sujet Poster une réponse





  Powered by Fire-Soft-Board v1.0.10 © 2004 - 2019 Groupe FSB
Page générée en 9 requêtes
BlackOne par Grimmlink